mirror of
https://github.com/Jokiller230/puzzlevision.git
synced 2025-01-18 18:03:06 +01:00
17 lines
353 B
Nix
17 lines
353 B
Nix
{
|
|
lib,
|
|
pkgs,
|
|
namespace,
|
|
config,
|
|
...
|
|
}: with lib; with lib.${namespace};
|
|
let
|
|
cfg = config.${namespace}.tools.cachix;
|
|
in {
|
|
options.${namespace}.tools.cachix = { enable = mkEnableOption "Enable the cachix binary cache service on your system."; };
|
|
|
|
config = mkIf cfg.enable {
|
|
environment.systemPackages = with pkgs; [ cachix ];
|
|
};
|
|
}
|
|
|