mirror of
https://github.com/Jokiller230/puzzlevision.git
synced 2025-01-18 18:03:06 +01:00
16 lines
416 B
Nix
16 lines
416 B
Nix
{
|
|
lib,
|
|
namespace,
|
|
...
|
|
}:
|
|
let
|
|
inherit (lib) types;
|
|
inherit (lib.${namespace}) mkOpt;
|
|
in
|
|
{
|
|
options.${namespace}.admin = with types; {
|
|
name = mkOpt str "Jo" "The short name of the system admin.";
|
|
full-name = mkOpt str "Johannes Reckers" "The full name of the system admin.";
|
|
email = mkOpt str "system@thevoid.cafe" "The E-Mail of the system admin. (Used for system services by default)";
|
|
};
|
|
}
|