puzzlevision/modules/nixos/admin/default.nix
Jo 84bfdec3f2 feat(modules/nixos): W.I.P add forgejo service
feat(modules/nixos): add admin module for system wide admin data
2024-12-27 20:37:00 +01:00

16 lines
416 B
Nix

{
lib,
namespace,
...
}:
let
inherit (lib) types;
inherit (lib.${namespace}) mkOpt;
in
{
options.${namespace}.admin = with types; {
name = mkOpt str "Jo" "The short name of the system admin.";
full-name = mkOpt str "Johannes Reckers" "The full name of the system admin.";
email = mkOpt str "system@thevoid.cafe" "The E-Mail of the system admin. (Used for system services by default)";
};
}