nix-config/modules/nixos/common/bluetooth/default.nix
Jo fde4abd59d refactor(module): clean up some module inputs
feat(module): add use-lix option to nix module

feat(module): update fish config for catppuccin
2024-09-10 10:46:16 +02:00

32 lines
704 B
Nix

{
lib,
pkgs,
namespace,
config,
...
}: with lib; with lib.${namespace};
let
cfg = config.${namespace}.common.bluetooth;
in {
options.${namespace}.common.bluetooth = { enable = mkEnableOption "Enable bluetooth support on your current system"; };
config = mkIf cfg.enable {
environment.systemPackages = with pkgs; [ bluez blueman ];
hardware.bluetooth = {
enable = true;
powerOnBoot = true;
package = pkgs.bluez;
settings = {
General = {
ControllerMode = "dual";
FastConnectable = "true";
Experimental = "true";
KernelExperimental = "true";
Disable= "Handsfree";
};
};
};
};
}