nix-config/modules/home/common/ssh/default.nix
Jo 57d067d501 feat(modules): add server archetype
feat: WIP add "absolutesolver" system and "cyn" user *wink wink*
refactor: clean up some comments and remove empty lines
2024-09-18 21:21:48 +02:00

41 lines
693 B
Nix

{
lib,
pkgs,
inputs,
namespace,
config,
...
}: let
sshDir = "${config.home.homeDirectory}/.ssh";
in {
home.packages = with pkgs; [
openssh
];
programs.ssh = {
enable = true;
extraConfig = ''
AddKeysToAgent yes
'';
matchBlocks = {
"github.com" = {
identityFile = "${sshDir}/id_ed25519";
identitiesOnly = true;
user = "git";
};
"gitlab.com" = {
identityFile = "${sshDir}/id_ed25519";
identitiesOnly = true;
user = "git";
};
"bitbucket.org" = {
identityFile = "${sshDir}/id_ed25519";
identitiesOnly = true;
user = "git";
};
};
};
}