nix-config/modules/home/apps/development/zed-editor/default.nix
Jo 57d067d501 feat(modules): add server archetype
feat: WIP add "absolutesolver" system and "cyn" user *wink wink*
refactor: clean up some comments and remove empty lines
2024-09-18 21:21:48 +02:00

26 lines
456 B
Nix

{
lib,
pkgs,
inputs,
namespace,
config,
...
}: with lib; with lib.${namespace};
let
cfg = config.${namespace}.apps.development.zed-editor;
zed-fhs = pkgs.buildFHSUserEnv {
name = "zed";
targetPkgs = pkgs:
with pkgs; [
zed-editor
];
runScript = "zed";
};
in {
options.${namespace}.apps.zed-editor = { enable = mkEnableOption "zed-editor"; };
config = mkIf cfg.enable {
home.packages = [zed-fhs];
};
}